gvdbilt wrote:If you are trying to connect to the Postgres database running on your Linux server FROM your desktop you should NOT try to start the postmaster service on the desktop!! Remove the postgres installation from your desktop as quickly as possible. Download PT without postgres and install that.
I tried that first. It says "PT cannot run without postgres" and refuses to start - that's why I had to install it again WITH postgres.
Also the /etc/postgres/pg_hba.conf file on the Linux server should give all systems in your home network access: "192.168.70.155 255.255.255.0" is really exactly the same as "192.168.70.159 255.255.255.0". It means that all IP addresses in the range 192.168.70.0 through to 192.168.70.255 are recognised, as indicated by the last 0 in the netmask.
Is that right? It seems to conflict with the previous answers I've had on this thread.
So you could replace both lines with "192.168.70.0 255.255.255.0" or even "192.168.70.0/24". These last 2 are each others equivalent.
I couldn't get it to work at all using the "/24" suffix... even the laptop fails to connect with that in there.
Anyway, if you can connect from your laptop you should also be able to connect from your desktop. I would suggest looking at the configuration parameters that PT has, like username, password (case sensitive!!) and the host name or host IP address where you run the postgres database.
I don't think the program is getting that far - the "can't connect to database" warning box appears so quickly that there's no way it has had time to send the info to the linux server, have it processed, and then send the "failed to connect" message back to the desktop. It's practically instantaneous. Click "connect" and then I've barely had time to remove my finger from the mouse button when the box appears to tell me it's failed.
I'm pretty certain that either a: the "connect" packets aren't even leaving my XP desktop at all, or b: something on the linux machine is blocking the traffic from the XP desktop on the required port.