I have decided to migrate my database to FreeBSD server - because the initial tests indicated that running the pgsql on a separate server increases performance. It is true: the lookups are faster but if I click the Refresh button I sometimes get the error "Unable to connect to database: <db_name>" PostgreSQL version:8.4.4 OS: FreeBSD 8.1-STABLE, hardware: CPU: Intel(R) Atom(TM) CPU
[email protected] (1676.70-MHz 686-class CPU), 2GB RAM
Solution: As it turned out FreeBSD pgsql has the default setting for max_connections set to 10, and PT uses more than this so I got it up to 30 and it works like a charm. Also set the shared_buffers to 8MB from the default 800kB.
Question: how many "max_connections" and "shared_buffers" PT3 requires to avoid any future problems.
Thanks.