Hi,
I have PT3 set up in a VMWare virtual machine. Earlier today I made what turned out to be the fateful decision to move the virtual machine. Since doing so the VM itself has been fine but pokertracker isn't. I get the initial welcome screen and then a window pops up asking me to create a new database (which fails if I try). If I cancel out of that window a "critical database error" window pops up (cos it can't find a DB to use). Exiting out of that window then takes me to a "Select Default Database" window in which my old database is shown but greyed out.
What I notice in this window is that the postgresql version display is 0.0.0 so I assume that pokertracker is failing to connect to postgresql. And the following postgres log extract confirms that:
18 01:24:48 GMT LOG: incomplete startup packet
2010-02-18 01:24:49 GMT LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
2010-02-18 01:24:49 GMT LOG: could not receive data from client: No connection could be made because the target machine actively refused it.
Now, the postgresql service is running and I have nothing unusual about my configuration within the VM. Indeed, I only moved the VM from one folder to another on the same host!
Unfortunately, I know nothing about postgresql. So can someone help me out with troubleshooting and fixing this problem? Should I uninstall postgresql? What will that do to the existing database (wherever it is)?
Regards,
david
